Jak v Excelu dosáhnout toho, aby se existující vzorec v buňce nepočítal

Krátká užitečná noticka, kterou jsem si chtěla poznamenat, co kdyby se někdy hodila. V programování se nezřídka stává, že je potřeba nějakou část třeba dočasně „vyřadit z procesu“, říkává se v tom případě, že se tzv. „zakomentuje“ – vloží se mezi/za značky, mezi něž se jinak vkládají komentáře, třeba pro zpřehlednění a jako pomůcka pro budoucí návrat do zdrojových záznamů.  I v Excelu se občas hodí, aby se třeba výpočet vzorce v buňce zatím jen připravil, ale ještě nebyl funkční, nebo dočasně znefunkčnil.

 


Na programování, ač znám jen základy, jsem si vzpomněla proto, že i v Excelu se postupuje podobně. Také se vlastně vzorec, který nemá být funkční, tzv. „zakomentuje“ v případě Excelu to znamená, že se před „rovná se“ vloží tzv. horní apostrof (krátká čárka před), ovšem apostrof se nesmí zaměnit za čárku, kterou se označuje diakritika, dlouhé samohlásky. Na české klávesnici se tudíž vkládá kombinací kláves SHIFT+klávesa s přehláskou, obvykle bývá hned nalevo od ENTERu, či v jeho blízkosti. Nebo se apostrof napíše tak, že se přidrží levý ALT+39

 

Když před vzorec, třeba =SUMA(A2:A9) napíšeme apostrof, tj. '=SUMA(A2:A9), v buňce se zadaná funkce nevypočítá a naopak se celý vzorec ukáže. Může se to takto i vytisknout, takže by se to hodilo třeba i pro přípravu výukových materiálů, při vizuálním porovnávání vzorců atp. Samotný apostrof se přímo v buňce, která není v danou chvíli aktivní k přepisování, neukazuje. Apostrof na úvodu zápisu buňky se tudíž může teoreticky použít i u zápisu čísla, bez toho, aby se formát buňky měnil třeba z formátu čísla na text, nebo z formátu měny na text atp. Apostrof nebude vidět, zapsané číslo zůstane. Ale apostrof kvůli své formální neviditelnosti by mohl způsobit někdy i komplikace při dalším zpracovávání dat, takže jeho používání by asi mělo být střídmé a cílené.

Upozorňujeme v souladu s legislativou EU, že tento web využívá cookies, jako naprostá většina všech stránek na internetu. Dalším používáním webu s jejich využitím souhlasíte. Více informací

Cookies na této webové stránce jsou povoleny, aby vám umožnily co nejsnažší procházení obsahu. Chcete-li i nadále používat tuto webovou stránku je třeba mít cookies povolené v prohlížeči a klepnout na tlačítko "Souhlasím", čímž si zpřístupníte obsah.

Zavřít